Author Topic: Engine Management Light  (Read 2277 times)

0 Members and 1 Guest are viewing this topic.

Ove

  • Grease Monkey
  • ****
  • Posts: 338
  • Karma: 0
Reply #60 on: October 17, 2020, 11:40:31 pm
Took it out for a nice run today. Went like a train. Was even better than my ride home from the dealer, mainly because I checked the tyres and found the front was at 7psi!

I did notice a very slight weave when I picked it up. It was only on the faster part of the journey, about 2 miles of road, which I (wrongly) put down to the road surface. I went on the same road today, it was straight and true. Glad I checked the pressures. Don't always do that. Last did it about 2 weeks before it went in and it was in for a couple of months, so from 20psi to 7 in 10 to 12 weeks. No sign of any tyre damage. Valve? Will have to watch it carefully.

Anyway, ride was great fun and pleased to have my bike back.


Haggis

  • Grease Monkey
  • ****
  • Posts: 266
  • Karma: 0
Reply #61 on: October 17, 2020, 11:57:28 pm
Glad to hear your mobile again...👍🏴󠁧󠁢󠁳󠁣󠁴󠁿
Off route, recalculate?


Richard230

  • Grand Gearhead
  • *****
  • Posts: 3,458
  • Karma: 0
Reply #62 on: October 18, 2020, 01:33:08 am
With tube-type tires I always check my air pressures before every ride. The tires on my Bullet seem to leak about 1 psi every two days.
2011 Royal Enfield B5 500, 2018 16.6 kWh Zero S, 2016 BMW R1200RS, 2009 BMW F650GS, 2020 KTM Duke 390, 2002 Yamaha FZ1


Ove

  • Grease Monkey
  • ****
  • Posts: 338
  • Karma: 0
Reply #63 on: October 18, 2020, 10:23:19 am
That's a bit extreme. Sounds like you either have a valve leak, or a slow puncture. I lose almost nothing from my other bike (also spokes and tubes) and the same from the Enfield until this episode. The rear was fine, so I suspect a leaky valve on the front.