Author Topic: Battery Drain... need help  (Read 596 times)

0 Members and 1 Guest are viewing this topic.

AK Mike

  • Scooter
  • **
  • Posts: 96
  • Karma: 0
on: May 21, 2020, 12:29:55 am
Greetings all,

I've finally been able to start taking out the new Himmy and breaking in the engine.  But I have a VERY annoying battery drain that I just can't figure out.

Ever since I got the bike this past winter, if I leave the it sit for a few days, the battery will drain.  I replaced the stock battery, (since everyone says it's crap), and replaced it with not one, but two new and very good quality batteries... but to no avail.  I lose about 1 tenth of a volt every day.  So if I start out with 12.6 volts, the next day it'll be 12.5, the next day 12.4 and so on.  If I let it go for over a week, I'll have a dead battery.

The bike is totally stock... no accessories of any kind.  No heated grips or USB outlets... nothing.  What the heck would cause this?  The only thing I can think that uses some juice even when off is the digital clock on the dash.  Could that possibly be the cause?  If so, how do I disable that clock, (don't need it anyway).

Let me know your thoughts.


olhogrider

  • 650 Interceptor and C5
  • Grand Gearhead
  • *****
  • Posts: 2,503
  • Karma: 1
  • VEGAS!
Reply #1 on: May 21, 2020, 02:32:06 am
Here's a simple test, and bear in mind I don't have a Himalayan. Remove the positive cable from the battery. Put an ammeter between the positive battery terminal and the positive cable. In series, not parallel. So all the juice has to go through the gauge. You shouldn't see any drain but I suspect you will. Then, one at a time remove fuses. When you pull the one that stops the flow you have identified the circuit. Maybe it is something that can be switched off or possibly something with a short. Good luck.


Grant Borden

  • It's Time to Ride!
  • Grease Monkey
  • ****
  • Posts: 258
  • Karma: 0
  • It's Time To Ride!!!
Reply #2 on: May 25, 2020, 01:03:01 am
Have you looked at the rectifier/regulator? If defective it can cause the battery to go flat and/ or destroy the battery giving a similar symptom. This happened on my Classic 500.

Grant
2016 Royal Enfield Continental GT
2014 Royal Enfield C5 With Cozy Euro Sidecar


AK Mike

  • Scooter
  • **
  • Posts: 96
  • Karma: 0
Reply #3 on: May 25, 2020, 02:53:37 am
Have you looked at the rectifier/regulator? If defective it can cause the battery to go flat and/ or destroy the battery giving a similar symptom. This happened on my Classic 500.

Grant
Oh great... Thanks Grant.  Yet another thing for my electrically illiterate brain to try and wrap itself around  :-\

But I "think" from the little I understand about the rectifier/regulator, it seems to be working as intended.  When my bike is running at idle, the battery has a voltage reading around 14.3... steady, with really no more or less.  So the bike is charging the battery as intended, and right after riding, the battery voltage is up where it should be at around 12.6/.7 volts.  But the battery is just discharging, (faster than it seems it should), over time when sitting idle.  Of course I know than any battery will discharge over time, but it's happening with my Himalayan way too too fast.

But I will study up some more on the workings of the regulator/rectifier, so many thanks for the tip.


AK Mike

  • Scooter
  • **
  • Posts: 96
  • Karma: 0
Reply #4 on: May 25, 2020, 04:38:53 pm
Here's a simple test, and bear in mind I don't have a Himalayan. Remove the positive cable from the battery. Put an ammeter between the positive battery terminal and the positive cable. In series, not parallel. So all the juice has to go through the gauge. You shouldn't see any drain but I suspect you will. Then, one at a time remove fuses. When you pull the one that stops the flow you have identified the circuit. Maybe it is something that can be switched off or possibly something with a short. Good luck.
Thank you sir for that suggestion.  I had already tried that and it doesn't seem that any current goes through the meter.  Still stumped, but still trying other tests.


DaveNZ

  • Neophyte
  • *
  • Posts: 1
  • Karma: 0
Reply #5 on: January 13, 2021, 05:09:31 am
Got to this forum when looking for help. We bought four of these as rentals, and they all have the battery drain issue. Still using original batteries, but will look to change them. They all drain down in about 4 days, then you have to use a jump starter or charge them back up. I am now disconnecting batteries once charged - only have to reset the clock.
I believe it is the clock draining them - what else could it be?
Cheers
Dave
Central Otago Motorcycle Hire, New Zealand.


oldphart

  • Bulleteer
  • ***
  • Posts: 168
  • Karma: 0
Reply #6 on: January 13, 2021, 09:16:05 am
It's not the clock.
I've got a carby model and there is no battery drain at all. I've actually left it for a few weeks without a problem starting at the end of it.

As for what it is, I have no idea. In fact, I subscribe to the smoke theory when it comes to 'lectrickery.
Grandpa Slow

2019 Himalayan.


Toni59

  • Scooter
  • **
  • Posts: 80
  • Karma: 0
Reply #7 on: January 14, 2021, 11:31:29 am
If you can't measure a discharge current with your meter when all the consumers are off:
Is the meter sensitive enough?

If no discharge current is actually flowing in the motorbike, the battery should also discharge itself in the same time period when removed....

Regards
Toni


viczena

  • Scooter
  • **
  • Posts: 22
  • Karma: 0
Reply #8 on: January 14, 2021, 12:16:13 pm
To really trap the consumer, you need an ampmeter with milli Amp sensitivity. This is quite costly, but effective.
with that device you can follow every lead and find the leak very easy.
Something like this: https://www.amazon.de/gp/product/B00RGL98E0/ref=ppx_yo_dt_b_asin_title_o09_s00?ie=UTF8&psc=1