Author Topic: Front Brake Not Lighting Up Tail Light & Starter Not Working  (Read 445 times)

0 Members and 1 Guest are viewing this topic.

la_r3_cgt_rider

  • Bulleteer
  • ***
  • Posts: 114
  • Karma: 0
  • I ride in San Diego
Based on youtube videos, I am thinking that the combination of the tail light not lighting up when I engage the front brake and the fact that I can't get my bike to start with the electric start switch that it's possible that my brake switch may be dead?

Am I on the right track? If so does anyone know where I can get a new brake switch?

Thanks
2014 RE-CGT – Pegasus
San Diego, CA


Bilgemaster

  • Just some guy
  • Grand Gearhead
  • *****
  • Posts: 1,339
  • Karma: 0
  • 2005 Bullet 500ES in "Mean Green" Military Trim
Reply #1 on: October 27, 2019, 01:18:37 am
I don't have a nice sleek Conti, but if the front brake switch AND starter button both started acting up or crapped out at the same time on my old "Iron Belly" Bullet, I'd first be looking at the connections from the switchery within the front brake lever mount for anything loose or maybe corroded. My hunch would be a multi-wire connector had just slipped its moorings--probably just vibrated loose.
« Last Edit: October 27, 2019, 01:25:03 am by Bilgemaster »
So badass my Enfield's actually illegal  in India.


Kevin Mahoney

  • Gotten my hands dirty on bikes more than once -
  • Global Moderator
  • Grand Gearhead
  • *****
  • Posts: 3,563
  • Karma: 0
Reply #2 on: October 29, 2019, 10:48:08 pm
What he said
Best Regards,
Kevin Mahoney
www.cyclesidecar.com