HPRE

Menu

Members Rides

My G5 and I on the Coast


in
Members Rides

NField Gear

22 Guests, 3 Users
pmanaz1973, cafeman, wildbill
Welcome, Guest. Please login or register.
Did you miss your activation email?
February 11, 2016, 09:31:28 pm

Login with username, password and session length

 

Author Topic: Non Working Speedo fix.  (Read 526 times)

Ragmas

  • Grease Monkey
  • ****
  • Posts: 354
  • Karma: 0
Non Working Speedo fix.
« on: April 23, 2010, 04:05:31 pm »
This is primarily a heads up to those of you who may have this problem.  When you have fixed your flat front tire and put your wheel back on and you notice that your speedo does not work.  Before you take the front wheel back off, make sure you check the top end of the speedo cable to be sure that it was still attached to the speedometer. 

Another heads up regarding reattaching the cable to the Speedometer.  It is much easier, on the G5 anyway, to remove the head light completely to do this job. 

Also, if you think you may have buggered up the speedo gear on the wheel end you can always unscrew the little nut that attaches the cable to the gear to check to see if it turns with the wheel instead of taking the entire wheel off the bike again.

(Don't ask me how I figured all of this out.  ;) )
2009 G-5 Military
Little Falls, NY

REpozer

  • His Honorable Excellency, the
  • Grand Gearhead
  • *****
  • Posts: 2,970
  • Karma: 0
Re: Non Working Speedo fix.
« Reply #1 on: April 23, 2010, 09:03:02 pm »
You can also feel the speedo cable "seat" itself while installing the cable through the bottom pushing up.
2008 AVL Classic Bullet in British Racing Green
REA # 84 ( the first time)